After update firmware 0.0.5 autoleveling platform failure


after updating to firmware 0.0.5 I did some print without any problem..

Today I clean the platform and as always I did the auto-leveling but I can not finish it!

The control on the back is ok but when I get on the front is a continuous exchange between high and low with minimal rotations!

I turned off the printer, did the manual leveling and then I tried again with the auto-leveling but still nothing!

I’ve never had problems with 0.0.4 and then I think it is a firmware bug

Have any of you tried or can try? How can I fix ??

I have/had the same problem with the previous firmware. What I noticed was that when checking the front of the platform, when the nozzle touched the left hand side of the platform it would on first touch also deflect the platform (which it did not do on the right side). So I adjusted the back right adjuster so that it raised the back left up slightly and dropped the front left down. Then on the next attempt the auto calibration worked fine.

This is not a real solution as clearly the auto calibration does not work correctly on all printers.


other fix?

can someone post old 0.0.4 firmware??

I fix the problem ... I changed position to the rear screws and so I had to adapt to the new position with the front screws ... it was probably a defect in that position ... i don't understand.... :(

I have found on my printer the back is not very sensitive to the point that it can be off 1mm or more. and the front very sensitive making it very hard

I think there is a big in the firm wear . I had to override  it and do it manually to get my bed level

I don't bother with the firmware level assist, it is too buggy. I get the bed close to "level" (tram, really) by moving the printhead around by hand with the printer switched off (since there is no manual electronic X-Y control), then during printing I watch the first layer going down and if it is too thin or thick in some area I make small adjustments "on the fly". Once set, I find it very rarely needs to be adjusted.

So far as I know no even one line of changes in calibration for 0.0.5 was done overall it working same as with 0.0.4.

Best Regards

Thanks Martin… 😉

Also bed heating routine seems changed. It is twice as fast as before but... my last large print detached on one side and print failed. Never had a detachment since I bought the machine. At the begin of this last print I felt that it didn't start the heating process at all or it was so fast that I didn't notice it, maybe the heating process in 0.0.5 doesen't give the heated bed the time to go to full temp and so prints don't stick well.

I'll go back to 0.0.4 and check if it is a firmware related problem or is my heating bed that needs care.

I can confirm you that 0.0.4 seems to be quite more stable in term of prints sticking.

I'm printing the same piece that detached that is 196x40mm, so about the full bed width and the raft succesfully completed without any detachment. In the same print with 0.0.5 at this point it already failed and the right side detached and heavily curled.

While 0.0.5 has a few nice new features I'll stay with 0.0.4 until Zortrax makes a better heating routine.

The best would be if we could manually initiate platform heating. This way we can choose how long we wait for the bed to saturate before printing. You then can wait longer for a large print or you can just quickly start a small print. I hated how long the bed heated in 0.0.4… Sometimes it even got stuck completely.

I think the problem is not just the heating time but the max temp reached too. Usually the machine starts heating the perf bed right after being turned on, so you can wait 15-20 min before printing until it's hot. But I think that 0.0.5 also changed something in both the the max temp reached on the heated bed and maybe in printing parameters too, and this is why the prints don't stick well.

I suppose something also changed in the printing parameters because It seemed me that 0.0.5 does a slight better job in top of supports with Z-ABS, Less burnt marks, but I didn't have the time to fully test because of the continuous print detachments. In truth I hope Zortrax will test and try to make the top of supports with the same pattern as the top of the raft, since such a pattern gives the best flat and sticking surface and the easiest to detach from the piece at the same time. Maybe someone from the Zortrax team can please answer to those suggestions and considerations?

I think the problem is not just the heating time but the max temp reached too. Usually the machine starts heating the perf bed right after being turned on, so you can wait 15-20 min before printing until it's hot.

That was the case up until 0.0.3… If I’m not mistaken from 0.0.4 on the platform only heats to 60% or so when you turn on the printer. The heating up to full temp only starts when you start the actual print. I think they did that for safety regulatory reasons (so you don’t burn yourself with the printer just idling).

Don't think so. Even in 0.0.4 if you wait after turning on the printer 10-15 mins and you then start a print it already starts heating from 92-93%. It takes a while to go to 100% then anyway so maybe is just a bug that Zortrax team tried to solve in 0.0.5

please those who load the firmware 0.0.4 page zortrax is no longer available for download ...... it 0.0.5 is driving me crazy you can not print


Please make all previous firmware's available for download on your website.

I don't like the idea of only being able to download the latest "beta" (call it that or not) firmware.

As a result, I run only old firmware until I can confirm that the latest isn't giving people any significant problems.

(which, judging by the complaints, it seems like the latest firmware is a problem-child)

Please keep a back-log for us users to download.


That’s a good idea!

Making older releases of the firmware and ZSuite available in the download area is a good idea, but you can also archive them yourself on your local hard disk or elsewhere and re-load them whenever you like. I also usually them to the hard disk and install or unzip from there.