Platform is gone :(

I written to the support and i'm waiting for reply.

920 hours of work, 4 months of life, it's a v4.

Some people who get this error revert the firmware to previous versions.  

I had this happen once or twice and all I did was unplug the platform and then reattach, along with cleaning the platform connector.

Others have broke the one connector by citing the pins/solder with the scraper.

I tried rollback to 0.0.8 firmware but same error :(

I repost a post from me:


sorry for my delayed response - I had holidays :-)

Yesterday I could fix my problem and printed out my first carabiner.

Still waiting for the spare part, I was frustrated and I was thinking about the pin of the small connector on the perforated plate.

I did not found any spec for this, but when I switched on the printer without the mounted plate I got the message that there is no plate mounted on the display. (Exactly your error Message mc0676)

That means, the software has an indicator whether the plate is mounted or not. With a magniefier I inspected the solder point on the plate and detected, that there is a short between the left and the middle pin (view on the connectorside - not frontside of the printer). And this seems to be logic. If the female connector is connected with the plate both cables gets shortend and the software knows the plate is mounted. The right pin is in contact with the metal areas of the perforated plate and will get shortend with the noozle when both approaches.

After learning this, I was able to solder the pins of the connector to the plate.

And, tata, the printer works.

So I will have a happy Sunday.

Best regards


So you´re problem might be a defect connector oder solder point on the plate. With a checker device you should be able to find out the problem.

Original Post:

got your ticket, already replied :)

It seems to me that the molex style connector is unnecessarily small and in a very vulnerable place !  Would it not be better to use a larger connector and pace it not proud of the top surface ?

How that tiny little delicate connector has survived redesigns of the board to this day is one of the great mysteries that perplexes me in life.

I mean you have to put a fair amount of force behind a sharp scraping blade that will inevitably slip, and right next to the print is a pathetic little connector that belongs on the inside of covered electronics.

To boot, it clearly isn't made for regular removal... I mean you need to remove it every time you have to scrape a print off but it isn't designed for this, there is no way to properly grip it so you need to wiggle it out often by the wires, its an all round terrible piece of design.

To the OP - 

If you cant fix this with a firmware update then I managed to fix a completely broken off connector with the following advice from this forum - 

Looking at the board from the usual front (connector at back). Pin on the right is used for continuity detection with the print head for auto leveling/cal.  The two pins on the left are used for cable disconnect detection and are simply connected together (Zortrax controller can tell if the cable came off before ramming head into plate, by testing continuity between those two pins).

So if software doesn't fix it then try shorting the two pins on the left, as this will tell the printer that the bed is connected. The last wire connects to the metal on the bed for the auto-calibration, so make sure this works and be ready to switch the printer off by the main switch if that wire isn't connecting as it wont stop lifting the bed if it doesn't detect it  touching the print nozzle.