Camera Problems

i’m currently working on a 10 days Job with my new M300 Dual. I restarted my computer and now, when i try to get a preview with the camera it appears:
“another user is currently displaying the camera preview. Try again later”.
Any suggestions?


Hi, Marc.

Try to restart the printer and check if you can see the preview then.

Thanks for your quick reply.
That’s the reason why I mentioned the 10 days job. Would that jeopardize my job?
I know that restarting will fix that problem. It happened before. But why?

M300 Dual has a blackout response system, so you will be able to resume the printing process after restarting the printer.

Regarding the problem, it can be some process on the computer that interrupts the preview.
We’ve improved camera connection for M300 Dual in the newest Z-SUITE version, so you can update it and see if it improves the situation as well.

Thanks. I’ll try to reboot the printer.

Regarding the problem itself, I already have the newest version and I rebooted my computer system several times. So it’s not computer related. I even shut my computer down and tried to connect from another. Same issue. There has to be an old open connectionon on the M300.

Addition: Reboot worked. Print started again without problems and camera works. In my opinion it is only a temporary workaround,

Two hours later, same prob occured.

camera? what camera
I assume you are talking about the animated preview?? or am I missing something …having a senior moment?..etc…ahem

@macke500 Thank you. I have passed the information about the problem to our specialists. One more thing - which firmware version do you have installed on your printer?

@parakartracer M300 Dual has built-in camera for printing area preview. You can launch it in My Devices panel.

Thanks Marta.
I installed the latest firmware from your page when i got the printer.
Filename: Z-Firmware_V1-0-3_M300_Dual

ok yep
sorry haven’t bothered connecting it to a network
so assume you can only view the live camera if you have machine connected to network ?

That’s correct. You have to be connected to local network to connect with the printer via Z-SUITE.

@macke500 Thank you. We’re looking into that.

Hi Marta,

couple of updates and month later, but still the same error message :frowning:

Same problem here (M300 DUAL) I can use the camera when I am at office but whenever I take my laptop and go home, it says “another user …” is it hard like that ? Also I paused the print to try the camera then I cant resume the file from Z-SUITE. You need an update. You need very big… After all problems, if you put a camera in printer, please make an mobile app to use the camera…

Hi @Cntk3D,

Please note that both the printer and your computer should be connected to the same network in order to get camera preview and manage your prints via Z-SUITE.

I encourage you to have a look at Zortrax inCloud - Printing Management System. Our specialists are still working on providing new features, and you can access the site even via your mobile web browser. However, thank you for your suggestion regarding the mobile app.

Best regards,

Hi Karolina,
Thanks for reply. Firstly, yes my computer and printer connected to the same network with VPN when I at home. Actually I tried last evening and it worked. (I assume the answer for problem is we must close the Z-SUITE and camera before we take the laptop to reconnect in different time and place.)

The mobile app would be great. Thanks for your interest.

Best regards.

Any updates on this problem? I am having the same issue, and now it is 7/26/2021.

Hi @czhang,

what Z-SUITE version are you using? If 2.19.1 Beta - please, install 2.21.0 and check if there is any improvement. Is the printer connected to the same network as your computer? Have you checked whether the camera preview works in inCloud? Also, make sure the firmware is up-to-date.

Best regards,

Also reporting the same issue.

-Both the client and printer are updated to the latest stable firmware
-Both have been rebooted
-Network packet analysis shows that the data is being sent properly. [PSH, ACK] sequences are normal and report no RST/errors. Default server port 8002 is accepting connections. Client side firewall has an established connection and explicit allow for the port. Our router ACL also has an explicit allow.
-Using MMS/RTP/RTSP URL connections through VLC Media Player network streaming doesn’t work either.

This sounds like an application error. You may want to pass this info along to the developers.

Hi @emoya,

you mentioned having both printers updated to the newest firmware - but how about the software version (2.22.0)? Please, confirm this as well. Also, have you tried checking the camera preview via inCloud, as well as connecting the printer through the mobile hotspot?

I will consult the case with specialists once you answer the questions.

Best regards,