Firmware, Camera and Sleep mode on the M300Dual


Printer is always asking for firmware update to be installed 2.1.1 even that the firmware installed is 2.2.3 - see picture

Camera in printer is not working – yes, I have removed the cap :grinning: Always get the same message: There was a problem with the camera preview in the printer

Please include in next firmware the option for the printer to go into sleep mode after finish a print instead of waiting for confirmation. As an option for those of us that print long and overnight. Same as on M200.


Did you make sure there is no update.zar2 file copied onto the USB drive? Or does the printer ask for the update even if you turn it on without the USB?

As for the camera - did the problem occur recently (I was wondering if the camera used to work with some previous firmware/software version) or the printer is brand new?

Does sending files via Z-SUITE etc. work fine despite that? Also, what Z-SUITE version are you using?

Also, thank you for the suggestion concerning the M200 Plus.

Best regards,

I am also having issues with the Camera. Brand new M300 Dual. Everything else works fine.

Documentation on this machine is TERRIBLE. So many questions, so few answers.

Where IS the camera on the machine? NOWHERE does anything say I need to remove a camera cover EVEN if I knew what it looked like…

I keep getting the Problem with camera preview error…

I am running latest firmware. I have restarted machine. Wifi is connected - I can send parts to print via Wifi.

EDIT: Okay…I found the camera in the Right / Front upper corner. Took off the small, rubber cover. Tried to engage camera preview again. STILL getting problem with camera preview error…

Please help…

HI Karolina
Thanks for reply.

You right about the frimware - old one on usb stick. Deleted and problem gone.

Regarding the camera it has never worked for me.
Got this all the time:
There was a problem with the camera preview in the printer.
Will test with other computer today.
The printer was prucahsed in december 4. 2019



I am really glad we were able to resolve everything via support form :slight_smile: Thank you for your cooperation.

Best regards,

Hi Thomas,

Please, check your router/firewall settings - sometimes the lack of preview can be caused by blocked ports - 8001, 8002, 8086, as well as protocols (UDP and TCP). Double-check that. Also, make sure the newest Z-SUITE is installed.

Best regards,