Firmware-Update not possible

Dear Zortrax-Team!

I have to print something for a custumer ASAP and was stupid enough to update Z-Suite to version 2.24.
I have a M200+, Hardware V1, Serial Number Z9CEE10C7 with Firmware 1.4.

When switching on the M200+ says “The latest version of the firmware is installed. Update not available”

When I want to print, Z-Suite says it needs a firmware update on the M200+ (but the latest version is installed according to the printer)

Internet says I have to register my M200+ first, but there is no possibility to enter the pin from the registration website on my M200+ maybe because of the old firmware.

I tried to update using the firmware-files (2.5.9, 2.5.13) and a two different USB flash drives, but again no succes, M200+ says: “Either the file or the USB flash drive is damaged. Try to transfer the file again or use a different USB flash drive”.

To print my parts quickly, I tried to find an old version of Z-Suite but obviously they are hidden very well, so, just guess, no success again.

I found a solution that is very tedious:

  1. Copy Update File FW V 2.0 to USB drive, insert USB drive to M200+
  2. Install FW Version 1.5 from USB drive
    Attention, you mus download FW V 2.0, there you will finde V1.5, sounds mysterious
    Power off
  3. Copy Update File FW V 2.0 to USB drive, insert USB drive to M200+
    Power on
  4. Install FW V.2.0 from USB drive
    Power off
    disconnect USB flash drive with FW V 2.0
  5. Power on, now you will be asked to update to newest FW

I hope I could help somebody, it cost me 4 hrs to fnd this workaround
@ Zortrax…the doumentation for this upgrade is nonexistent

Greetings from Austria


Dear Christian,

to sum everything up - you did try to install 1.5.0 prior to 2.0.0 update, right? The firmware should be installed in the below order, as significant changes were introduced over the years: 1.4.0 → 1.5.0 → 2.0.0 → 2.3.0 (you will then be able to register the device: How to Register Your Device with Zortrax ID | Zortrax Support Center) → 2.5.13.

Also, please note that the most important information concerning updates is always provided in the changelog. This is why they should be done regularly:


However, if the printer does not recognize 1.5.0 file - please try to install 1.4.0 again (unless you managed to pass through 2.0.0 update, then please do not revert to 1.X.X one). Please do all the updates via USB, ensuring there is only one update.zar/update.zar2 file on it. If the device still does not recognize any update - the Android PCB might be damaged.

Could you provide any video showing what is exactly happening during the update?

Best regards