Firmware update on Apoller


#1

We want to update the latest version of Firmware for our Zortrax Apoller.

We first connected the device to our Wifi network via a dongle. As described in the Manual, we went to Settings>About Device, however we are not able to see the option, “Check for Updates” .

We then downloaded the firmware update file on a thumb drive and tried that approach. However, we are not able to detect USB drive or any file system through the Apoller Application menu. The user manual doesn’t specify any instructions on how to access the a USB drive.

Can you please guide us with instructions for both the approaches of firmware update?


#2

Hi, @smiatke.

This update needs to be done via USB. To update the firmware, you need to turn off the Apoller, insert the USB drive with newest firmware and turn on the device. Update process should start automatically.
Future updates should be available via Check for updates option.


#3

Thanks Marta,

We tried the USB drive based firmware update approach but the device wont read the update file while booting up. We followed the exact steps, i.e. inserted the USB before starting the device. First we had multiple files in the USB drive but since it wasn’t working, we removed all the other files and just kept the update file but it still won’t work.

Please find attached the images of the message we see after starting the device.

Is there any other way you would recommend?


#4

Hi, Sam.

Thank you for the picture. It seems that Apoller cannot read the update file from the USB drive.
Have you unpacked the folder? You need to place update.zar2 file on the USB, so that the device can update firmware.
If you have done all that, please let me know. I will consult the issue with our specialists then.


#5

Hi Marta,

Yes - we unzipped the folder. To keep it simple we also only kept only the .zar2 file on the USB and removed any unrelated files/data.

Thanks,
Sam


#6

Hi, Sam.
Could you try updating the firmware with another USB drive?