Limit extruder movement speed

I often have a layer shifting problem on my M300 Dual, and despite lots of attempts with greasing, cleaning, checking everything, etc. I couldn’t solve it.
However, I noticed the problem only happens when the extruder moves at high speed (for example when crossing an empty area or during dual material switching). A simple solution would be limiting the maximum travel speed, but I dont think there is such an option in settings. Is there any way to achieve this?

This is really important for me, because now I can only let the printer work when I am near, ready to pause the print (then home the extruder and resume) as soon as I hear the slipping noise. This is not he best when you have a 25 hours print in progress…

1 Like


It’s unbelievable because this problem has been going on for a long time with many people, there are a lot of forums talking about it and Zortrax can’t solve it. This machine costs 5000.- it’s not a 200.- amateur printer.

What I’ve already noticed is that even if the perpendicular between the X and Y axis is correct, the problem is still present. The lag does not come from the belts, it’s the motors that jump. I looked carefully at the displacements and it’s really the motors that jump and shift the layers. It looks like the motors are not powerful enough or maybe a problem with the driver, or output voltage.

In short, I’m also stopped in my production and it’s a mess.

Translated with (free version)


as written in my topic, I have exactly the same problem and have come to the same conclusion as you both.

I have been in contact with Zortrax for days about this and I am now getting new motors for the X and Y axis. I really hope that this will help. However, considering the accumulation of the same error reports here on the forum, I have little faith in this unless it is a new type of motor.

The interesting thing is that sometimes it works fine when printing for more than 2 days and then it shifts again after a few hours.

Likewise, you can’t reliably reproduce the Axis Check error, which makes troubleshooting difficult.

I am currently helping myself by placing the components in such a way that as few (unnecessarily) fast “empty runs” as possible are needed in the problematic X-axis. This at least reduces the probability of a shift.

Since there is no way from Zortrax to access the camera of the M300 Dual via smartphone (not even in the cloud is currently supported?!), I sniffed the camera stream and can now access it via app. So at least I see without sitting at the computer or printer whether I have to cancel the print or not.

We were going to buy more printers for our company (including the Inkspire) but right now that is definitely on hold as far as Zortrax is concerned.

Zortrax must FINALLY find a solution!

1 Like

Well, since apparently there is no solution I decided to sell this printer; it’s a shame having to do this after only few months of use but I can’t work with unreliable equipment. So far I collected this shifting problem, a major sensor malfuncion (the only workaround was to set the printer to ingore material jams, which can result in further print failures) and the inability to access the camera as mentioned by milbauer1701 and many others. In addition, I found the maintenance costs for this printer are really high (I already spent hundreds of euros in replacement parts).
Considering that I have other Zortrax models that work quite well I’m equally surprised and disappointed by the M300 Dual, I guess I’ll move to other brands for a better dual extrusion machine.

I wish I had known this issue before advising my boss to invest in this machine, we have all the issues mentioned above, this never worked correctly from day 1.
I have the old school m200 & m300 machines at home running with no issues that is why I pushed to buy zortrax.
All I can say is that I really feel stupid now, it is not the best when your boss and colleagues are waiting for this machine to deliver what it promised…

Did you get anywhere with the new motors?
Were they the same type or stronger?

Best regards

Here’s an update:

I actually received new motors and they ran a little more sluggishly, which I interpreted as a good sign. Unfortunately, they have no designation whatsoever, as they are probably cheapest China junk.

The first smaller prints were also back in order. Only last night with a relatively large component (I have by far not used the possibilities of the build space) I had again a layer shift in X direction.

I have just informed Zortrax about this again.

Zortrax has developed shit and sold way too expensive. They should finally stand by it and give us a final solution.

The printer is unusable and worthless. Zortrax is the manufacturer and must improve until the printer delivers what was promised to us.

The suspicion is growing that Zortrax is deliberately deceiving its customers and continues to sell the printer, even though it is clearly a misdevelopment.

We have to defend ourselves together against this!
Please all contact the “service” of Zortrax and be persistent! They take your money and sell you cheap junk!

We in the company have meanwhile finally blocked Zortrax as a supplier! And so Ultimaker has just sold another machine…

1 Like

Oh dear!

Thanks for the update but that is bad news indeed.

It does sound like a misdevelopment.

If Zortrax is unable to give you a satisfactory solution or money back you should give them a bad review on Google and Trustpilot. I think that has a high visibility and may deter other customers from getting into trouble.


I have no hope for a helpful solution from Zortrax. They just don’t have the printer under control and probably hope that we will eventually give up and resign ourselves to having wasted 5000€.

They continue to sell it as is and the number of complaints increases as well.

Clearly Zortrax will be viewed negatively if they fail to get a 3D printer to print.

But I want a working printer for my 5000€! Nothing more!

Have you informed Zortrax support about your problem? Do they help you?


I am still waiting for a reply.

Just to “cheer you up”. I’ve been struggling with this problem since November 2020… And I’m also waiting for an answer right now.