M200 Plate Height Issues

Hi,

So i've had my M200 for just under a month, no issues at all so far, its done around 90hrs printing.

I'm always careful to avoid hitting the rear plate cables when removing models and the models i print arent that large to be an issue.

Last night i ran a 9hr print and when i came back to the printer in the morning the print chamber was full of a big mess of extruded filament, when i tried a subsequent print, it was as if the printer couldnt recognize the bed height and was thus printing into thin air.

The up and down motors seem to work fine, nothing obvious on wobble or tightness, manual via the control panel moves of the bed up and down are fine.

I tried to re-calibrate but again it seems unable to find the right bed height, it moves the bed height, but no where near close enough to the print head and then seems to try and align in mid air, resulting in an error code on alignment.

I've checked the bed and cables and all look fine.

Please see video and pics, any help appreciated

https://www.youtube.com/kUxATnr1mK4

I couldn't play the youtube video to see what is happening but I would guess with your description of the issue it does not sound like an issue with either of the plugs on the bed. Usually if one of those plugs is not connecting properly then the bed hits the tip.

what is the error code that it displays? (may give a hint to the issue)

I am not sure what the issue is but I would look the ribbon cable (replace it if you can) or the Z axis stepper motor cable, (or at least have a look at the cables and plugs)

YT video doesn't work.

I would bet on faulty ribbon cable

Try printing that:

http://library.zortrax.com/project/ribbon-cable-tester/

and post results here. 

Fixed it, did a deep clean of the whole plate, dismantled, etc, and that seemed to work.