M200 Plus - ANNOYING BUGS in Firmware 2.0.0


#1

I have just installed on my M200 Plus the new firmware 2.0.0.
At first, I have reloaded the already present Z-ABS material, just to notify the presence of this filament to the printer that was showing on the screen the “Unknown Material” message.
Then, just to explore the new features of the firmware, I have performed an automatic calibration of the platform. During this process anyway, the extruder (positioned at its home position) tried to move beyond the physical limit of the switches on X and Y axes (with negative movements), making an unnatural and loud noise! Moreover, when the extruder has started heating, also the printing bed has tried to go beyond its lower limit, making again an unnatural and loud noise. Hmm…
Then, having a look at the new menu interface, I have found an annoying bug:
In the “TOOLS” menu, I selected the button “RUN LOWER FAN” just to test this option, but when I have deselected it, the upper fan has suddenly turned on, even if I didn’t turn on the “RUN UPPER FAN” option.
Now, if I turn on and then off the upper fan using the relative button, the upper fan turns off for just a moment and then it turns on again! Even if I disable that option and switch off and then on again the M200 Plus, the upper fan is still always turned on!
About 15 minutes later, I have unplugged the main power cable from the printer for a few seconds, then I have plugged it again. When I have turned it on, at the end of the booting process, both the fans was regularly turned off… I don’t know what was causing that strange situation… maybe the extruder was still too hot after the filament loading and the platform calibration processes…
Any deeper investigation by Zortrax is anyway appreciated, thank you!


#2

Hi, @giufini.

Thank you for letting us know about these issues, we’ll look into that.

No need to add multiple posts, we see them all :slight_smile:


#3

Dear @giufini,

unfortunately yesterday I decided too to upgrade my brand new M200 Plus from FW 1.4.0 to 2.0.0:

  • FIRST REBOOT: my regular Z-ULTRAT material wasn’t recognized anymore and on the screen I had “Unknown material” message, but a simple material load solved the problem.

  • CALIBRATION: the platform went all the way down without caring about the endstop and maintaining the Z-Axis stepper motor running for a couple of seconds, making a bad noise, like the endless screw skipping steps. Not good!
    Also X and Y Axis tried to overshoot under the zero point, but in this case the motor, still running after returning to zero, didn’t make any weird noise at all. But anyway I don’t think that maintain the motor spinning when already at zero point could be useful and I’m sure that could damage the unit or maybe make it consume motors and mechaincs sooner. Please watch on this, because it’s dangerous for all the M200 Plus out there!

  • PRINT: Again the platform went all the way down with bad sound. Next start going up, but… for some reason the extruder returned to zero point (front left) and the print began without verifying the zero position of the platform!
    How is this possible? How can you ensure that the platform is really at the right position? Do you really take care of the number of revolutions from the bottom to the top? For sure this isn’t as precise as verify the zero once arrived at the top, don’t you think? I’m really scared about this behavior.

RGB STRIPE COLOR: during the print with FW 1.4.0 we had white color coming from the RGB led stripe. But now for some kind of reason it’s blue. Remember that we have a camera inside the printing room, and the blue color isn’t bright enough to ensure the right view of the printing process through the camera.

Please take seriously our bug reports and investigate deeper on this, because we really risk to damage our printers. I really don’t want to send it back to you for repair and for sure you don’t want to repair thousands of M200 Plus printers damaged by weird zeroing and step motors that continue to spin also at the end of the travel for all the axis. Also the missing platform zeroing at printing start it’s not easily understandable.


#4

Thanks for the feedback, @mystic.

I have passed your suggestions to our specialists as well.

Platform’s position is now checked only during calibration, this is not a bug. This solution provides more repeatable results of calibration and makes printing with glass plate possible.


#5

I have also updated my M200 Plus to Firmware 2.0.0 and having an issue.
Updating went smooth and went through calibration without any problems.

When I try to print my files from my iMac, Z-SUITE gives me a message that material is “Not loaded” but I have already loaded the Z-ABS on the printer. I have rebooted the printer and the Z-SUITE, deleted the printer from Z-SUITE and reconnected but still gives me the same message.
I can send the file via wifi and print by manually selecting the file but is very annoying.

Anyone else facing similar problem?


#6

This is a small problem caused by the new firmware that erased the previous filament settings stored in the printer memory, but it is easy to solve: simply use the load filament procedure of the printer selecting the same type of material that you already have on the back of the printer.


#7

Thank you for the reply.
Like I wrote, I have already loaded Z-ABS on the printer after the update and is still happening.
I have unloaded and loaded multiple times but Z-SUITE keeps showing me the message.
On the printer it tells me that Z-ABS is loaded.


#8

Do you have the newest Z-SUITE 2.11.1 installed?


#9
  • I loaded filament from another brand and Z-suite 2.11.1 says material unknown.

  • I have to unload z-ultrat twice before the filament is loose.

  • During the start of the unload proces, i had the error message error #4:4 Platform heating plate: H

    fault eater failure.


#10

Hello Marta,

Yes I do have 2.11.1 installed.


#11

@FLurk1967 please, check your heatbed connections.

@ZICO We’ll check what it is with the lack of information about material.


#12

Restart the printer en the fault is gone.