M200 Plus will not update Firmware


#1

I have tried all I can think off to update the firmware on my M200 plus

I keeps giving me an USB error, I have tried several different USB’s no difference down loaded the file separately.

“UPDATE ERROR”
“Either the file or the USB flash drive is damaged try to transfer the file again or use a different USB”
I haven’t printed anything yet!
Think I have a bad printer?


#2

It create a folder called “LOST.DIR”


#3

Hi!

I assume you have some older firmware version installed and you want to go directly to 1.4.0. Sometimes it gives such an error. Please try the following:

  1. Install the 1.1.2 version.
  2. Install the 1.2.0 version.
  3. Install the latest version.

Let me know if that helps.


#4

I’m getting this error trying to update from Ver 1-3-2 to Ver 2-1-3. Will I really have to do it one version at a time or will I be able to skip over a few?


#5

Good morning even I can not update the firmware, I download the latest release 2.1.3 on the key supplied with the printer, but it does not keep me going. It tells me that I have the latest version available: 1.1.1
please help me


#6

Hi, you need to install (via USB) 1.5.0 update.zar2 file which can be found in 2.0.0 folder. So the update process should look like that: 1.3.2 -> 1.5.0 -> 2.0.0 -> 2.1.3.


#7

Hi, 1.1.1 is the old firmware. You will not be able to update to 2.1.3 directly. You will find all firmware versions here. Install the following versions in order (via USB): 1.1.1 -> 1.2.0 -> 1.5.0 (you will find the file in 2.0.0 folder) -> 2.0.0 -> 2.1.3.


#8

Thanks everyone, I uploaded to 2.1.3. but I can no longer find the Italian language in the latest versions … it is possible


#9

Sorry, it took me a while to get back to this and longer to remember to confirm that this did work as you said. Thank you.


#10

Hi, thank you for the update. I am glad it worked.