M300 Dual Error #7 - no firmware detected

Today after removing the filament I have received the following notification: Error #7 - no firmware detected. I have tried to turn off and on the device, but it didn’t help. Any ideas?

Hi, Dariusz,

thank you for reaching us via support form. We will do our best to provide you with a solution to your problem as soon as possible.

Best regards,


Is there a solution for this problem already @KarolinaZortrax ?
It happened the same to me. Is there a way to reinstall the firmware?


I had to replace the motherboard.

Hi dgrzesiak,

Is there a tutorial for that? Where did you buy a new motherboard? Do you have any idea what was wrong with the previous one?


Hi @TiagoS,

when facing a communication error (#7, #8, #22) - it is crucial to check the connections first, as indicated in the troubleshooting manual. However, if this does not help - there might be a problem with the motherboard, Android or LCD display through board. Therefore, it is always best to contact us via support form, so we can look into the matter more closely. Thanks to additional information - we might verify the root of the problem remotely. Also, you can purchase programmable parts (motherboard, Android) directly from us then

As for reinstalling the firmware - you can simply revert to a previous version, just as you were to install a new update via USB. Once you copy the update.zar2 onto the drive, insert it and restart the printer - the file should be detected automatically. Or, you can tap on the “check for updates” bar above the error code - the USB will be read as well.

Best regards

1 Like

There is a tutorial on how to replace the motherboard on the manufacturer website. I didn’t buy it, I have a valid warranty and I got it from Zortrax. Everything went fast and smooth.

1 Like

I have tried reinstalling the firmware.

When I use the same firmware version that was there previously I get the message "Error #15 - Cannot update the firmware.
When I use newest firmware viersion I get the message "Error #8 - Unable to communicate with control board.
If I insist installing the newest firmware viersion I get the message "Error #22 - Unable to determine bootloader version.

Next step will be checking the connections between android board and motherboard.
My machine is also within warranty as well.
I have sent a support form nonetheless.

Thanks for the help.