M300, Plattform moves down, not up

I just started to experience a problem with the platform trying to move down, not up, when starting a new print. I used the printer to print a part and it worked fine. when I started to print another part the platform started to act as though it wanted to move downward, not upward, as it should. Under maintanance I can move the platform up and down with no problems.
I turned off the printer, then tried again. I checked for the lasted firmware but it appears I have the latest. I also re-created the zcode, check the print settings to make sure I did not change something that could cause the platform to move in a downward direction.
I tried a couple of times, turning off, then on, the printer.
Any suggestions I should be looking for that is causing this problem?

I found the problem, with the help of previous posting by others with the same problem. The small three pin connector towards the rear of the platform can become faulty, I think causing a short. I unplugged the connector, checked it for damage. It’s not in great condition but after cleaning it I plugged it back in and started a print. All seems to be working now but I’m planning to purchase a connector, on the wired side, and replace the old one.
I’ll see if I can replace the connector on the platform. If not I’ll just have to buy a new one.