M300 Plus Will not read zcode


#1

I have tried on multiple sd cards and flash drives that 100% work.

It DOES see older Zcodex files and NOT new zcode.

Z-Suite will NOT write .zcodex it will only read older zcodex.

How should I print on an M300 plus?


#2

Hi,

What firmware version do you have?

Which Z-SUITE do you use?

Please send me the zcodex files that do not work. I’ll check them.

Kind regards,

Marcin


#3

Hi @Montrose,

also, please make sure you set the right printer model in Z-SUITE - otherwise, the software will generate .zcode files which cannot be read by M300 Plus. You can also set your default printer here: File -> Preferences.

printer%20model

Best regards,
Karolina


#4

Thank you!

I did not realize that there was more than one model of M300 single extruder, that solved the issue.

Can I use third-party slicers with M300 plus? I have found converters to zcode but not zcodex?


#5

Hi @Montrose,

You are welcome, we are glad you found a solution.

We do not recommend using third-party slicers - Z-SUITE is our dedicated slicing software, and please note that the printer will not recognize any other files than .zcode ones (.zcodex/.zcodex2 files are dedicated for M200/300 Plus, M300 Dual, Inkspire).