Mac Osx don't run Z-suite V 1.1.0 and 1.0.2 after system update 10.10.5

My Mac Retina 5k don't want to run any Z-suite after the apple software update 10.10.5

I tried also to re-install the Mono framework but seem nothing happens... any idea? or i will wait a new version?

fortunately i have also my old imac 27" with snow leopard that crunch everithing!!

(else my 1.1.0 dont want to open any obj....)

 I wrote issues on this from previous versions.  Sometimes it needs a jump start.

Did you go into applications, Zsuite, show package contents, contents, mac os, and start zsuite there. -- If that doesn't kick start it to start working correctly then

Try Library, Frameworks, mono-frameworks, versions, current, bin,and then click on mono-sgen. Then try to open Zsuite.

Hope it helps you, it always helped me when I had the issue.

I just tried it, but it does not work ... I also read the post about it but I had not tried it because regard an older version of OSX than mine. before the update mine has always worked well with Zsuite.

fortunately I still have the other old MAC I hope everything will be resolved with a new version of Zsuite

Thanks a lot anyway for your contribution!

Usually it is the computer and not the program.

Did you try to open it when Activity monitor is open and then click on Zsuite process and take samples from all the processes associated with Zsuite?

That sometimes works too.

Tried but not work, remain "not responding" state

But i tried now to open it again, in the activity monitor was signed as ever "not responding" but after about 3 minutes, it start!

Now seem to work well every time i try to open it


I found it to be the frameworks glitch that needs a jump start.

I think that other 3D programs steal some files from it and causes it to freeze or stop working for some other 3d programs, but that is just my theory.

I haven't a clue but glad its working.

First time user of Zortrax ... long time 3D printer with both commercial and open source printers. Fortunately the second post helped me get Z-Suite running but that is a painful sequence that should be unnecessary. The importance of having Mono installed was pretty obscure on the download page. Though it still didn't work... and many Mac users will have no idea how to get to /Library. 

Zortrax really need to wrap that install up neater OR give a full set of instructions to jump through all the hoops for Mac users. 


Yes it can be pain staking sometimes, but I am not sure I agree with you that most mac owners don't know how to get to Library.  

From my experience, most mac users are well versed in the basic workings of the OS, considering they all came from the horror they call windows where you need to get to the program files to make that OS run. lol

But maybe I am wrong because unlike Windows, Macs sometimes never need to go into program files to make the OS run proper because it is superior. I am wondering why I even posted. hahah but since it is written, why not. 

:lol:  :lol:  :P  Cheers

At uni I would say about 70% of my cohort wouldn't know even after they googled it. I come from a technical IT background and I would say 80% of my friends would work it out without googling and 99% would after googling.

Most people go for a Mac these days because they feel they won't have to know/do something like this. This is the same market who will go for a Zortrax or an Up printer instead of going for a reprap/open source printer.

I also have a iMac Retina 5k with 10.10.5 running Z-Suite.  I noticed the "Not responding" the first time I ran it - kind of a delay.  It seem to have been doing some caching or doing something.  After some time it started working fine.  Its been running great without issues since.



Seems that actual Z-Suite 1.2.0 isn't compatible with OS X El Captain. Compatibility error message upon open.

I've OS X El Captain beta on my mac, and Z Suite works well