Need fixes for Error #19 & Error #8


#1

Our M300 Plus is a little over 6 months old and we love it!

We have received Error #19 - GUI doesn’t receive packages, a couple times in the past but it has been resolved by power cycling the printer.

This morning I came in to find a failed 13 hour print with error #19. When I power cycled the printer I received an Error #8 - Unable to communicate with control board - Unknown bootloader version, when it powered up.

Need help in getting this resolved quickly as we have parts backing up in our print log!


#2

Hi,

First of all, make sure the printer has been updated to the newest firmware version (2.4.3).

Second of all, I would suggest checking the connections on the motherboard and Android PCB. At the same time make sure the screw securing the LCD Display Through on the motherboard is tight.

Does the error #8 occur immediately after turning on the device now? Please, contact us via support form - we will help you to resolve the issue.

Best regards,
Karolina


#3

Karolina,

Thank you for your response.

I upgraded the firmware to 2.4.3 and still no luck.
Error #8 occurs at startup. It seems like the printer is taking a long time to boot up then the code gets thrown.

I unplugged then plugged in all the connections on both boards and check the screws, still no luck…

I filled out the support form at 9:00 am my time yesterday (EST) and have not heard anything back yet…


#4

Hi Karolina,

did you solve the problem?


#5

The problem has been resolved.
It required replacing both boards on the printer.

In the end, it took us around two weeks to get the parts required to get the printer backup and running.
As much as I love the printer, I feel the tech support could be a little more responsive.

We wound up buying an M200 Plus while our M300 Plus was down to help us catch up our backlog,
I would highly recommend having a backup printer.