New computer with a problem

I have this error message when I launch Z-Suite or some other apps so I know it is not a problem with Z-Suite, but maybe some of you may have encountered this same problem and have fixed it. Attached is the popup.


Try this

Thanks, Heavenly

Tried several of the fixes but none worked for me. I'll continue to look some more. If I click on the OK button a few times, I can eventually access Z-Suite and once this is done I have no more problems until the next time the computer is started.


did you happen to look in that dll file and see if what it says is missing is actually not there.. I just looked in mine and it is.. Also.. Look for this update and see if has been installed.. KB2999226 

Thanks Kyle,

Yes the .dll files are present and I have downloaded several recommended microsoft fixes and none of them correct the problem. I had a microsoft tech guy on the phone for almost an hour today and he couldn't fix it either. It all started when

I downloaded Outlook 2016. There are quite a few similar problems on the internet, many of them have to do with an installation of Office 2016. 

I did try to install KB2999226 but the error message "The update is not applicable to your computer" appears. I think I will reinstall the operating system.


Do you have installed NET framework?


I have several versions of C++ Redis. Is this the same as NET?

I installed Windows 10. Problem solved!