Problem with Z-Suite after update to 2.23

Hi Everyone

I have just updated my version of Z-Suite to the last one (2.23)
when I launch it and try to create a new project, I can’t select my printers, the window remains empty
I had to downgrade to the 2.18 to be able to use the software

Any Idea of what is the problem?
thank you

Hi @Druon,

please, try to clear the given folder first: C:\Users\USER_NAME\AppData\Roaming (remember to copy printing profiles first in case you saved your own ones), . If this does not help - reinstall Z-SUITE in a different catalog. If there is still no improvement - please, contact us via support form and we will look further into the matter.

Best regards,

I allready tried this, but no improvement. I also tried to uninstall and reinstall after deleting the files, still nothing.
I will try on a different computer


I am sorry to hear there is still no improvement. Once you try to run Z-SUITE on a different computer - please, let us know the results via support form, so we can look into the matter and provide a solution.

Hi !

I just installed Z-Suite 2.24, and it finally works !!!

thank you for your time

Hi @Druon,

thank you so much for your feedback. Our specialists are constantly working on improving our slicing software, hence we are glad to hear the issues have been resolved.