SD card error #200

Are there some requirements for SD cards on the M200?

I have 3 new SanDisk Ultra 64GB cards that always report "Error #200" on the M200, altho they work fine in my PC.

Specs are: 80 MB/s SDXC I, digit "1" in a U, number 10 in a circle. Just got them from Amazon.

I tried reformatting (using Windows 10 - exFAT). Same result.

Maybe (but probably not) related - the little spring in the SD card reader that pops out the card broke soon after I got the printer. It's no big deal (just need fingernails to get the card out).

I know, I've been there.

For some reason it's difficult to use this brand of SD cards. I recommend to get a SDHC with a capacity of 16 GB maximum.

Bigger cards do not work well or do not work at all.

If the spring inside the reader broke - it could also be a potential reason of the failure.

Sounds like the M200 firmware (or possibly the hardware) doesn't know how to talk the newer protocol used by 32+ GB cards.

Should be an easy thing to fix in a firmware update.

I'm passing it to our firmware guys.

Thanks for vigilance.