Some problems with new printer


our company just gets the new M300 Dual. Unpacking and installation so far was very easy, so thx to that.
But now we have some problems:
1.) Network problems: it seems, every time the printer is started, it uses a new mac adress (android mac adress randomization). This is very bad in our company, because with a new Mac adress the printer gets a new IP. It also leads to the problem that the camera is not working (as also stated in some other threads in this forum, “camera is used by another user”). For our network configuration we need a fix mac adress and we need to edit the host name for our network rules
2.) Warping: trying to test print with PETG and Z-Premium Support, models taken from the zortrax library. Small models work fine but when it comes to a larger print area, warping begins and we had to manually abort the print. We are using the glas plate (not the perforated plate)

Any help would be appreciated


Let me please answer your questions.

  1. Have you tried providing a Mac address once the Static IP (not DHCP) has been chosen? This works with the Ethernet only.

When it comes to problems with the camera - we are aware of the issue and our specialists are doing their best to provide a fix as soon as possible.

  1. Take a look at our tips for printing on the glass plate. You need to apply a plate adhesive first.

Thanks for the response

1.) Yes I tried it already. In that scenario I get a connection timeout.
The problem is even if I set up a mac adress (or use the given shown in the network settings) the printer uses another mac adress.
By the way the wireless option is working fine but we aren’t allowed to use wireless connections, only for testing.
2.) I forgot to mention that we prepared the glas plate with an adhesive spray. We had another printer before this m300 dual also with a glas plate and therefore we knew to prepare the plate.

Hi Christian,

Thank you for tyour reply.

  1. As you get a connection timeout, please, double-check if the printer is configured correctly. The printer should not obtain a new MAC address with the Static IP.

  2. Can you please check if it works with a glue stick? Also,did you do the manual calibration before the print?

1.) I checked the configuration. But even if I set the IP manually with each restart of the printer the mac address changes
2.) we prepared the glas plate with a glue stick, glue spray, hair spray (that worked on the older printer very well) … small area prints are very good but if it is larger than 4x4cm warping begins

What plastics do you want to use with hair spray?
Hair spray is effective for PLA or for flexible plastics (like NINJATEK)

For ABS, or PETG, or NYLON, it is best to use DIMAFIX or a GECKOTEK sheet or PEI sheet to stick to the glass.

  1. Thank you for the information, we appreciate it. I have passed it further and our specialists will look into the matter.

  2. This seems unusual, adhesives you use should have worked with PETG. Also, I am sure you performed the manual calibration before starting the print. We need to check that on our side.

H everybody,

we have the same problem that every time the printer is started, it uses a new mac adress.
“For our network configuration we need a fix mac adress and we need to edit the host name for our network rules”
Same apllies for us!
If you check the options in the printer, there is always shown the same macaddress. That’s definitely a no go!!!
And i do not understand the relation betwenn a static and dynamic IP and the mac address!??!? The mac should never change (except doing that on purpose).

Camera Problem: same issue.


I do understand your concern. Our specialists are already aware of the issues you have listed. We are working on them.


just a quick report.
Yesterday I installed the new firmware and with that I could connect to the camera. But the network problem is still there, in a manner a bit heavier because now I only get a network connection if I also have a wlan connection active, otherwise I get a connection timeout
And today I installed the new z-suit. And voila, no more camera preview, the program says that I have problems with the preview function on the printer …
I’m very disappointed, it’s very anoying thatg such key features do not work and it takes so much time.

I wanted to ask if there is any progress concerning the network problem. It is absolutely annoying to have a new printer with such problems, especially if the random mac adresses normally are features for wifi settings and not for ethernet ports.
Is there a way to substitute the usb wifi adapter with a usb ethernet adapter to have a workaround?

Hi, did you install newest 2.1.1 firmware? We have improved the ethernet connection stability Please, give it a try first.

Yes, I updated the firmware before my post and did several tests. The only thing that changed: if I power on the printer, it finds no network connection and I get the message, that I have to check the network cable. That is really funny because if I connect via wlan and print something, the printer finds a network connection (and as before the network adapter with randomized mac adress), uses it without problems. But when I restart the printer all is gone.
Sorry, but this is not what I expect from a new printer that is called “industrial”. The simple network configuration must work, must be configurable for the needs of companies.

I’m very frustrated and we are on the verge to give the printer back

Hi Christian, thank you for further information.

Can you please explain what do you mean by the fact that the printers finds no network connection and the message concerning the network cable occurs? Can you record any video?

Coming back to the problem with MAC address - could you please doble-check if you get a message “MAC changed” after typing it in? This is important.Our specialists have checked different configurations on several printers and providing that all details are typed in correctly - the connection should be established successfully. Could you also tell which MAC address are you typing in?



  • power on the printer, ethernet cable is plugged (it doesn’t matter if the printer is plugged over an additional switch or directly on our core switch). Once up, I have no ethernet connection. If I want to configure ethernet, I get the message to check cable connection
  • activating wlan: I get a fixed MAC address and therefore a connection to our network
  • printing with wlan activated: I get a camera signal from the printer, all is working fine. The special thing: after some hours I get an IP address over ethernet cable connection and I can configure the network. But after every reboot of the printer I get a new mac address (the actual address is 86:9B:8C:09:C9:90 and you can see it is an internal (not fixed) address).
  • configuring the ethernet connection: it does not matter what mac address I set: after a reboot the system sets a new address despite of what is in the settings. But to say clear: the wlan usb adapter always has the same address (a correct fixed hardware address), the ethernet adapter always has a different address and that is a non-fixed internal address. And that is a no-go in our network.

btw I am not allowed to take videos or pictures from anything in our rooms

Hi Christian,

Thank you for your detailed response. Our specialists checked your MAC address and everything seems to be working fine on our side, it did not change after restarting the device. Unfortunately, without any videos or pictures - it is difficult to provide further suggestions. Most likely, it seems there are some problems with the network configuration.

ok, new problem: i cannot finish prints because the material (Z-Ultralat Plus / Premium Support) are sticking in the hot end, so I have to clean the extruder as described in the support section. But …
1.) I cannot unload the support material. I only get the option on the printer to load new material. This makes it very difficult to clean the extruder, to dissamble the parts
2.) I cannot directly load new material in extruder A. I always have to unload “unknown material” and then load the Z-Ultralat Plus … why “unknown”?
So if I have cleaned the extruder, i can print for a few hours. But then one material gets stuck, the print stops and I have to cancel it. And then I cannot load the material again. If I try to the material starts to feed in but failed with the message to insert the material. I can then resume but after some seconds there is a stuttering noise and I get the message that loading the material failed.
Firmware installed: 2.1.3