Stepper Gear is malfunctioning

I've had my M200 for about a month and I've done 3 prints with it.   The last print was a large logo done in Zabs a week or so ago.   It took a long time and I was curious why the last layer was half printed (now I realize the filament wasn't feeding at full capacity).  Since then I've realized the stepper gear is probably malfunctioning, and not do to a clog.

At first I thought it was a clogged hot end.  I've taken the stepper apart, I've cleaned the nozzle with the .3 and .04mm wire.  I've tried different Zabs spools and when I go to load a new filament the Stepper gear is working but rotates a bit then back then forwards more in a non-smooth or ratchety fashion.  Oddly enough the abs comes out likes its ready for a print but not fast enough.  I have taken the motor out and cleaned the stepper gear, made sure the entire filament feeder mechanism is clean.

I'm hoping the ribbon cable I've got coming to me from Octave will solve this.  I'm asking if this is common to have the ribbon cable be the problem and have the stepper gear rotate as if it's half clogged or jammed?  Doesn't make sense to me that it would be the Ribbon cable from a mechanical standpoint?

The only thing I haven't done is soak the the nozzle for 10 hours in Acetone as recommended on the forums.  I assumed that I don't need to because I can pass the .04mm wire through freely and looking down it's shaft see light coming through the nozzle.  Can someone please confirm any of this?

Super frustrated with this printer so far and faintly remember that when it worked, it worked great.   Lastly I purchased this recently from Octave and I remember but don't have pics thinking it was odd that the nozzle was blackened, I'd assumed that it was some sort of varnish that is put as a coating on the outside to protect it somehow.  I'm now wondering if this was used previously, sure hope they aren't re-boxing returns, or selling refurbished M200's as new.

However I would also like to point out that when I asked for a Ribbon cable replacement, Octave responded quickly to my email and got one out to me that's on it's way, so the customer service is good.  Just feel like maybe the printer is a lemon or something.

Thank you!

Did you also run a drill bit through the feed tube? Seems weird that after only 3 prints it would clog.. I'm sure Octave would never ship out a used or refurb unit. They are tested from factory for function. That me be what you noticed. I have had mine over a year with minimal problems. The cable could be the problem. If the stepper gets intermittent voltage due to a broken wire it will act out like a child.. ;) Just because you can pass the 4mm wire through the hole doesn't mean the nozzle is ok.. There may be a hardened piece stuck in the "chamber" of the nozzle. (larger hole) When you load filament, it may push it back into the main path causing resistance. I might be able to call you this week to try a few things. I'm working 7 days a week for the next 3 weeks so we'll see. I'm down in Littleton.. I'm sure this will get figured out.. Very simple system..

Here is a quick phone video showing the extrusion speed and the sound from the Stepper gear.

That's nowhere near normal speed.. Try moving the cable around near connector when loading. See if you can find the sweet spot.. If not, Something is plugged. Don't worry about the stepper. They are almost bullet proof..

Thank you Kyle,

I didn’t run a drill bit through the feed tube.  I will try that tommorow.  I have a small shop that I keep my printers at in Broomfield that is 20 min. away…  I would greatly appreciate talking with you maybe this week sometime when it’s convenient for you.  I believe your right about Octave and as I stated previously, their response was great.  I do hope the Ribbon cable is the culprit and your response that is may be is definatley putting me more at ease about this printer!  I appreciate it.

I will also soak the nozzle in Acetone as I've heard recommended elsewhere on the forums.  Thanks for clarifying that it still may be clogged!


Ah!  just saw your post.  Good to know it's even close to normal speed.  I foolishly kept trying to print this way thinking It was close and if I let it run a while, it might un-screw it's self up!

How do I figure out what version of M200 I have?  Is it a number in the serial # or something?

he did it to me, no problem, it is a remnant of the filament into gear stepper motor; extract the filament with the procedure filament unload, clean gear, blowing it cuts the final part of the filament (5 cm is sufficient) and charging the filament, you'll see that you solve.

Thank you Cicio3D.  I did clean the motor face and stepper gear out thoroughly as shown in the Zortrax video's.  I hope it's the ribbon cable.

Check the white connector on the stepper itself. Julia had a pin not seated properly in the connector on her latest Zortrax.

As Kyle said - there could be a hardened piece or brass chip in the nozzle.

Try to load filament without nozzle.

Nozzle removal tutorial:

Also take the whole stepper out (4screws) and look down the feed tube

Hi there @co3Dprints,

I am one of the Technicians here at Octave, I can put a few questions or concerns you have to rest. For starters, Octave will not ever and has not sold a printer as new if it is a refurbished or returned. We sell them as they are, we do maker sure they function and replace things like the nozzles, people like myself and others tend to buy these ones at the reduced price. Selling them as anything other than what they are would simply not be good business practice. The nozzle was probably blackened on the end of the nozzle tip but no further because we do a full printer check before we send any out. This check includes things like Loading up the newest firmware, making sure the printer can heat up properly, extruding, auto-leveling is functioning, and a general inspection of all goods and packing material to ensure the printers leave our office in good functioning condition. 

We also keep detailed logs of all printer inspections in the event of issues. 

We hope that this issue can be resolved quickly and get you back up and running. I my self know the frustration of having a printer down for periods longer than expected.


Easy way to test it.

I would try taking hot end off and thence if the stepper motor does the same thing. If so then something is a miss on top. If it feeds through and no issues then its the nozzle or hot end tube. 

Is the hot end getting enough heat? I had this happen to me and one of my wires was loose ion the hotness and it wasn't heating high enough to push through at normal speed. When I fixed the wire the hot end melted at normal temp and the stepper worked perfectly.

Good Luck


Had the nozzle soaking in Acetone all night and recieved the ribbon yesterday.  Hopefully fix this a.m.

@Kyle - What size drillbit do you recommend?  I remember reading that somewhere but man that seems harsh to use a tool with sort of cutting edge to be passed through (I realize gently) into any machined cavity.

@Michael -  Thank you for clarifying and sending a replacement ribbon straight away!  I'll speak highly of Octave.  Do you guys sells other parts?  I don't see a nozzle or perforated platform for sale on your website?  Do you expect to get any Zultrat or Zhips in soon?

@HeavenlyCreations - Great tip.  I remember having the nozzle off and reloading fillament and the stepper if I remembered right was rotating correctly.  So maybe I still have a clog in the feeder tube.  I'm going to test this first at your recommendation.

Thank you to all the great help on this forum, very much appreciated!

I don’t remember and I’m already at work. . It’s right at just smaller than 1.75 mm. Make sure to heat extruder first.

Ok, thanks

So I loaded new fillament and with the nozzle off.  It loads freeley and the Stepper doesn't ratchet at all, it turns as it supposed to.  Then when I put the nozzle back on which I've soaked all night in Acetone and made sure I can see daylight with the .04 needle; when I load filament then it starts ratcheting and won't work.  I'm guessing I need a hotend or nozzle at this point.  I'm out of time to try and clean the feeder chamber so I'll have to work on it later or tommorow.

One other thought. . Make sure the set screws that hold heater and temp sensor are tight. Block might not be getting hot enough.

OK.  That makes good sense as I watching it this a.m. I felt like it seemed to be passing the full size fillament fine through the heater but if there was more resistance, from having the nozzle it thats what would make it stop working.  I feel like after all of this it maybe the hotend thats faulty.  But man I'm just guessing anymore.  I'll post videos as soon as I have them downloaded of this as I think yourself and people with experience can help pinpoint problems easier in a video than my rambling on...