Stepper motor stuck without filiment


#1

Dear All,

Long time follower first time poster here, this issue is driving me crazy and desperately needed for advice.

Has been using this printer for years and last week all the sudden the stepper motor seems to be stuck/clicking. ( Ribbon cable was replaced recently)

I have similar issue before but managed to solved by replacing a new ribbon cable.

To start, I tried to load without filiment but the stepper motor still not rotating or just clicking, so it is not the problem with stuck hotend of nozzzle, then I replace the ribbon cable, still doesn’t work. Then I replaced the PCB and still cant get it working. Lastly , I unscrew those 6 screw on the stepper motor and left it hanging and try to use “load material” to rotate it but it still clicking. ( so its not because of friction or anything)

I tried measure the voltage from the PCB on 1A,1B,2A,2B and I got a fluctuating between 0-20V. Just wondering if the voltage suppose to be constant or sending pulses or signale while loading material (to rotate the stepper motor).

I tried to connect it with my others DIY Nema 17 stepper motor and it does the same thing. My guess is the stepper motor need to be replace but the signal i measure seems to be very odd. If it is the stepper motor problem then it should rotate my nema 17 stepper motor right ? Also possibly because the current is not enough for the stepper motor. But if it is really the control issue and I have replaced the PCB and ribbon, so only remaining is monther board ?

Your help is greatly appreciated ! This is driving me crazy !

Kind regards,
Tff


#2

Think I found the problem, the last thing i suspect is the ribbon which I replaced two weeks ago got damaged again.

is this two pin suppose to be connected? after rechecking everything, I decided to do a point to point connectivity test again. Both time is the same pin broken, can someone advise if these two pin suppoer to be connected ?