Support jam error each build

Hey there, I love my Inventure, but I’m starting to have issues with my support material jamming and causing an error at the beginning of each build. It’s solved by simply unloading and reloading…but that’s kind of a pain. Any thoughts what might be causing this to happen? It thankfully does not jam during a build. I’m printing with Z ultra plus and Z support premium in a cartridge.


Hello, I have the same problem and only two week old printer. In my case it causes deep scratch to the print table. (fortunately there were 5 tables in the package)

I am using Zortrax support material and external PETG. And the same fix, load and unload again…


Hey Jouni,

If your nozzle is hitting the print bed it sounds like its out of calibration. I assume you did a platform leveling calibration procedure? I do it each time I change out a platform otherwise the same thing will happen to me. If it is close enough to hit, that means its close enough to block the nozzle and possibly cause a jam. That said, it’s odd that reloading material would fix this. Curious to hear what the experts at Zortrax say.

Hi guys,

Thank you for your feedback. I spoke with our specialists and they are working on a fix.

Best regards,

Hello, In some cases I just remove the printed part, not print table. So then it should keep calibration? After that I am going to make calibration every time when I remove and change platform.


Please remember that nozzle alignment should be done after platform calibration.

Best regards,

The same thing has happened to me 4-5 times. Somewhat deep dents and long scratches on platform with terrible noise. For some reason Inventure sometimes leaves support nozzle in down position but software thinks nozzles are levelled: platform is raised and crashes are inevitable.

I tried to machine, sand off the horizontally moving brass inside a bit using minidrill to prevent any hindrance from moving but don’t know yet if it helps. I’m still waiting for my cable.

There is pbobably some design or software issues unsolved in Inventure. And they are perhaps never solved.