Top surface Z-PETG print

I’m printing with Z-PETG on M300 printer, with external material settings. Prints are ok, nice walls surface. But when printing larger area top surface layer, it is wavy. I was trying with different settings - fan off or 20% or 80%. Also tried lowering density of top surface layers to 90%. Finaly I replaced new nozzle. But top layer always printed with waves. One layer before top seems ok, but then on top surface it makes waves.
When I print object with smaller top area, there is no problem as can be seen on first picture chess piece in back of picture.
Z-PETG spool is dryed. What should I try to get better top surface?

I would like to point out, that one layer below top surface prints fine. Only last layer surface becomes wavy.
So I think there is problem with last layer setting only. Or could there be some hardware problem - extruder cable ?

Hello @dmk,

could you share .zcode and .stl files?

Also, why are you using the external material profile when printing Z-PETG? Did you chanage extrusion temperature, print speed etc.?

The top surface looks as if it was overheated. Apart from increasing the fan speed (you can try setting it to 100%), it is recommended to take the side covers and HEPA Cover off while printing Z-PETG.

When was the last time you replaced the hotend and heater&thermocouple? One of these parts may be worn-out and cause such an issue.

Best regards,

Thank you for reply.
I’m printing without HEPA cover and side covers. In the room is stable 21°C.
I used external material profile because I have Hotend V3 installed on M300 (non Plus) printer. I found it ok to use it so and I think it’s not problem as I used it so for long time now. That’s why I set extrusion temperature to 240°C, as for M300 Plus printer PETG profile. Instead of 254°C on M300 profile. You mentioned that top surface looks as if it was overheated. Should I set even lower temperature? Maybe I can try with 230°C ?
I replaced hotend and heater 150 printing hours ago. I didn’ replace extruder cable for longer time. Could there be problem in extruder cable?
Can you explain me Density setting in Surface Layers-Top/Bottom section? Is it how much material is loaded for those layers?
Also I always unload Z-PETG material after print and load Z-HIPS material to protect hotend with nozzle.

I attached stl file and z-code file.

print PETG plosca.stl (180.6 KB)
print plate PETG.zcode (5.4 MB)

I solved problem by lowering extruder temperature from 240°C to 235°C and lowering Surface Layers-Top-Density to 80%. That was with Z-PETG material. Now I started using Addnorth PETG and by experimenting I found out best temperature is 225°C and Top Layers Density 90%.
Thanks for help.


thank you for the update. I am really glad to hear you have solved the problem by tweaking these parameters. As for the Surface Layers (top/bottom) - you can just actually set their number, since density only applies to the infill, raft or the first layer of the model. But yes, in general, this setting applies to the fact how much material is used.

Best regards,