Trying to print with Z-Glass. Filament gear keeps slipping?

I decided to try Z-Glass for the first time this morning, and I noticed right away during the material swap that the gear that feeds that filament to the extruder keeps skipping when I use Z-glass. I wondered if this would clear up once it was loaded and printing, but it does not. The gear keeps slipping, which then disrupts the extruder, and botches the entire print. Anybody know what gives?

To the best of my knowledge, I am using hotend V2. I purchased hotend V2 when I bought my M200, and swapped them out before even turning on my printer for the first time. Does Zortrax do these upgrades themselves before shipping printers? Perhaps I inadvertently replaced hotend v2 with hotend v1 when I swapped them out?

Thanks in advance!

share a picture of your hotend so we can say if you have the v1 or v2 equiped. Just for the info a v1 hotend can print zglass as well as v2. I have a v1 on one of my printers and never had a problem with zglass. 

I see.

I'm also wondering if it could be where I have my own custom filament holder mounted. It's mounted on the wall above my printer, high enough for the feeding tube to have a good six or seven inches of clearance to the spool. I thought working with gravity would put less stress on components, but now I'm wondering if it's too much force pushing down on the feeding gear, causing it to slip.

Anyhow, here are the hotends I have.

This is the one that was on my M200 when I got it last month:

3166

20160419_141950.jpg

3167

20160419_141957.jpg

3168

20160419_142006.jpg

And the one I've been using since day one:

3169

20160419_142329.jpg

3170

20160419_142449.jpg

They are both V2 hotends.

Well, I suppose we can rule that out then, haha.

I occasionally have some filament that slips in the feeder and ruins prints. usually it is just a small section of filament on the spool where it is smaller than 1.70 mm.

I cut about a foot of filament off the spool and re feed the filament and most times it starts working again perfectly, other times more is needed to be taken off. 

Try using a micrometer and see what size the filament is where it is slipping. I actually had a company replace some filament before because the whole roll was way too small to catch but it is rare. 

Cheers

Thanks for the tip. I'm off to grab my calipers.

Everything measures fine on the calipers. I cut about a meter, tried again, cut another meter, still no dice.

It seems to start taking it just fine, but eventually it reaches a certain point where it just starts slipping. I tried to help guide it into the extruder, but it just keeps slipping.

Swapped it out with some neon orange Ultrat and that's working perfectly.

Strange.

I think more force is required to press the Z-glass through the nozzle than compared to Z-Ultrat and Z-ABS due to the filling in the material, and if there is old residue in the nozzle it may cause the problem you are describing.  I think a nozzle change/clean may solve your problem and make sure that the flat cable to the extruder head is seating properly. Also clean the brass tube that goes into the hot end with a twist drill (using hand force). Do it with a heated extruder! For the nozzle, use a twist drill first (also hand force), I think it's 2.5mm and then the 0.4 mm wire that came with the machine. Remember to remove the nozzle with a heated hot end.

- Try dismantling nozzle and check if it still skips while loading filament

- Does any other filament works fine after using Z-Glass?

- Could be that the small bearing inside extruder could be too close to motor wheel - you may try to load filament as far as you can (glass) and loose 4 screws a bit, then push cover little bit to the left and screw it back. (photo attached).

- Check if bearing hasn't been damaged (http://support.zortrax.com/extruder_bearing_exchange/)

- Try moving ribbon cable back and forth during loading filament

Please, record me a video (short one, to see that slipping). 

Swap the nozzle with a new or a clean one and you will be ok.