Unexpected Error on Z-Suite


#1

When I hit “Preview” in Z-Suite I get a message “Unexpected error”
Before my computer was on windows 7 version and now it’s on windows 10 version.
I have the same version of Z-suite and the stl file
Since the computer is in windows 10 version, the Z-suite software doesn’t work.

Can you help me ?


#2

Try to completely uninstall Z-Suite e then reinstall it, it might help.


#3

I have tried to uninstall and reinstall.
I have tried to another version.
I have always this error.


#4

Hi,

Does this happen with all .stl files or just a specific one?

Make sure you have newest .NET Framework installed, as well as Visual C++ 2013 and 2015/2017. Also, please note that Z-SUITE 2 will work on a 64-bit system only.

Best regards,
Karolina


#5

Hello,

Yes with all .stl files.
I have the last version of .net framework and visual C++ 2008, 2010, 2013, 2015, 2017, 2019
My system is on 64 bit.

Best Regards


#6

Hi @Bart_bd!

Please check this topic and the solution provided by one of our users.

Let me know if that helps.

Kind regards,

Marcin


#7

Hi,

I followed the topic but the problem is not resolved.


#8

Hi,

Could you take a look at the description of the error in the Windows Event Log Viewer?

Please pass me a screenshot, if possible.

Kind regards,

Marcin


#9

Hi,

The problem is resolved.
The next key was enabled :

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\FipsAlgorithmPolicy]
“Enabled”=dword:00000000

After put the enabled to “0”, the slicing of z-suite started
Thanks


#10

Hi,

I am glad to hear you managed to resolve the problem. Also, thank you for sharing the solution with us - we will keep it in mind.

Best regards,
Karolina


#11

I had the same issue with the same solution in October 2020. “Unexpected Error” when clicking on preview. The solution required disabling FipsAlgorithmPolicy and restarting Z-Suite.

setup:
Windows 10, version 2004 (OS Build 19041.508)
Z-Suite 2.15.1