Z-Suite download link not working?

Just purchased a printer and tried to download the software but nothing happens when I click on the download link. I tried using a different browser and a different computer but the same issue happens where I can click all I want but nothing happens. Am I missing something? Are the links broken/down at the moment?

Same problem here. My Z-Suite 1.0.2 was not updating automatically until now so I tried it manually. But when I click the link nothing happens. In the left bottom edge I only see the message:

javascript:readSerial(false, '790');

I also deleted the "old" version of Z-Suite, but nothing happened except that I can´t use the printer from now on. :)



Is there any other way to download the software..?

No problem here - tested with IE and Chrome, try to update Java.

Best Regards


Hello Martin,

I also tried updating Java, but it did not work.

When I tested it today it worked fine. Perhaps it was only a temporary problem. 😉

The print quality is great with the new software! Thank you!