Z-Suite on Wondows 7 Pro in VirtualBox - no model view


#1

Hello,

I was having trouble with running Z-Suite on Windows 10 (1903 update). Not a single version worked correctly. With v2 there where problems with .Net framework redistributable 2015 instalation (I’ve got newer version installed and I don’t want to mess with it). So I’ve decided to install Z-Suite on a fresh Win7 Pro system on VirtualBox machine. Unforunately with no luck. I’ve tried versions: 1.12.2; 1.13.1.1; 2.8.1; 2.11.1. In each case the Z-suite installed correctly and I was even able to run it but no view of 3D space was visible. No errors was shown. When I double cklicked an .stl file to print (simple cube shape), no model was shown in Z-Suite.
What might be the problem and how to fix it? I haven’t found any answer for my issue in this forum.
3D acceleration as well as 2D acceleration is turned on in VirtualBox, 256MB of video memmory is assigned.

Best regards,
Martin.


#2

Hello Martin,

Please note that in order to run 2.11.1 you need to have VC++ 2013 and 2017 installed (Z-SUITE 1.X.X required 2013 and 2015 ones). VC++ 2017 can be downloaded here. Please, double-check that - really important.

At the same time, make sure the newest .NET Framework is installed. Once you have checked what I asked for, we will look further into the matter.


#3

Hello Karolina,

On my Windows 10 machine I’ve already got installed VC++ Redistributable 2013 (version 12.0.21005) as well as VC++ Redistributable 2017 (version 14.13.26020) and yet Z-Suite v2.11.1 during installation asks me for additional installation of VC++ Redistributable 2015, which I cannot install beccase the newer version of VC++ is already installed in my computer. Please find attached screenshots.


37%20AM
37%20AM%20001


#4

Hello Marcin,

Thank you for providing more information.

I assume the second setup window occurs when you want to omit the installation step (VC++ 2015), right? We will look further into the matter.


#5

Hello,

No. The second window occurs when i try to instal VC++ 2015.
If I try to cancel installation of VC++ 2015, the entire setup terminates. The Z-Suite v2.11.1 does not allow me to install it without installing VC++ 2015.


#6

Hello,

I spoke with our specialist. In general, you should be able to complete the installation despite cancelling the installation of VC++ 2015. However, can you please try to uninstall both VC++ 2013 and 2017, and try to download Z-SUITE once again then?


#7

Hello Karolina,

Thank you for the reply. I do not want to mess with the VC++ 2013 and VC++ 2017 as my other important software depends od it.
But I tried to install Z-Suite v2.11.1 once again and clicked cancel when prompt for the installation of the VC++2015 apreared. The installation of the Z-Suite really did contiune. Everything seems to work ok. The prompt is missleading because is says that VC++2015 is required but in fact it isn’t if the VC++2013 and VC++2017 are already installed. This should be fixed.
Anyway. Thanks for your help.
The topic can be closed now.


#8

Hello Marcin,

Thank you for the update. I am glad to hear that you were able to complete the installation. I realize that you did not want to uninstall previous VC++ versions but, actually, reinstalling them should be the first thing we should do.


#9

I have a similar problem. ZSuite launches but everything below the toolbar is black, no possibility of adding an STL. I have VC++2013 installed, but VC++2017 will not install, it says there is a version already installed and I would have to uninstall that first. In the installed programs, VC++2015-2019 is installed. I seem to have netframe 4.8 latest version. What do I need to do? The Mac version of ZSuite no longer works, and now the windows version too…


#10

Here are screen shots of what it looks like, and the installed software. This is after I uninstalled VC++2015-2019 which allowed me to install VC++2017. But the behavior was the same.


#11

Hi there!

  1. Do you have an external monitor connected to your laptop?
  2. Have you upated the drivers of your graphics card?
  3. Have you tried to change the resolution on the display?

Kind regards,

Marcin


#12

No external monitor.
Drivers are most current.
Display resolution makes no difference.

However your suspicions being with the display controller, I tried changing a few things. This is running in VMWare and I had Direct X and OpenGL turned off, as it causes problems with a 3D CAM program I run. With those turned on, ZSuite seems to work. Can I assume that ZSuite requires either Direct X or OpenGL or both?

This is made necessary by the discontinued support for the Mac OS. Is the long term future for ZSuite Windows only? My guess is you were using Windows.Forms in the Mono Framework which is 32 bit only, while 32 bit is no longer supported by the Mac OS. I’d like to know if there is a goal of continuing support for Mac OS in Catalina (10.15) and beyond, or if this is the end of the road as it will influence my decision on future Zortrax equipment purchases.