Z-Suite problems on Mac

I posted a lengthy explanation of my experiences with this software and Zortrax's support on a 3dhubs thread entitled, "New Zortrax M200 Software crashes mac". I spent a whole day installing and uninstalling to learn what I've posted below. That 3dhubs post contains a lot of unnecessary "story" but here's the "cut to the chase" version:

  • If your Mac is on OS X 10.9 Mavericks or earlier, Z-Suite 1.5.1 will not run. Z-Suite versions 1.4.1 or earlier will run, however, the Split Object function won't work and if you stick with that version you will miss out on future improvements and/or bug fixes. 
  • Z-Suite 1.5.1 runs fine on OS X 10.10 Yosemite and 10.11 El Capitan. In my case, the first time I tried to open Z-Suite the app icon just "bounced" for quite a long time (2 or 3 min?) but then Z-Suite opened and has worked fine since then. 
  • Regardless of the OS or the version of Z-Suite, you must install Mono Framework version and only that version. 

Note 1: If you've already installed any version of Mono other than, I suggest you go over to that 3dhubs post for info on how you can uninstall it and start fresh. 

Note 2: I'm on OS X 10.11.4 (early 2008 Mac Pro, SSD, 14 Gb ram) - Z-Suite slices slowly (because it's running within Mono?) but does a good job. I'm a 3d printing noob but as has been said, the M200 just works.