Zortrax M200 Plus Screen goes blank and stops printing

Hi all, I have problem with my M200+ lately. It randomly gets blank screen during printing, and the printing stops. I can resume it after printer restart but it happens again.

First time it happend is when it was updated to 2.6.7. and material was changed to Z-ABS2 ( used it for the first time).

Blank screen also happend in idle, when I try to change fillament, go trough settings, etc.

  • I tried formating USB. ( No change )
  • I tried changing material. ( No change )
  • I tried reseting it to factory default. ( No change )
  • I don’t have WiFi dongle, it’s connected via LAN, tried to unplug it. ( No change )
  • I tried to fix it by reversing it on older firmware, but when printer was on, when I plug in USB dongle on any USB port, immediately goes blank. ( No change )
  • Tried using other USB dongles. ( No change )
  • Solved that by inserting USB than starting printer. ( Printer works and installs older firmware )
  • I have put it to older versions 2.6.3 and 2.6.0, it starts printing, but it goes blank randomly again but not as often ( on 2.6.0. accours less than on 2.6.3. ).

What can be the problem and what to do next to diagnose?

Z-suite that I use is latest version.


Hello Nikola,

if you have not checked the connections yet - please check them as indicated in the troubleshooting manual. One of the wires might have got loose. Reattach the LCD display through board and remove the signal adapter (if it is installed) so Android PCB will be connected directly to themotherboard. If the problem still persists - Android PCB might be at fault (since it is possible to resume the print).

Please reach us via support form so we can look further into the matter and provide a solution (if possible - take a video when the blank screen occurs).

Thank you.

Best regards,

I have the same problem i solve it cleaning the down cooler and the power supply cooler