Smoke / burning smell help


#1

Whenever I am heating the hotend to print something. Alot of smoke is coming from the hotend and it smells pretty bad.

I already replaced the hotend, thermo couple cable, extruder motor, checked the fans, literally everything.

But still whenever I want to print something. Smoke is everywhere and this burning smell.

How could that be? If I replaced everything.

Is this normal? Is the Printer broken?

Hope you can help me
I only have the printer for 3,5 months now.


#2

Hi Maria,

Please, contact us via support form as we need to look further into the matter. A short video would help us to find a root of the problem. Also, make sure all the cables are firmly plugged into the PCB and that the screws securing the heater&thermocouple in the hotend are tight. You may also unplug the fans and turn the printer on, in order to make sure they are not causing any short-circuit.

Best regards,
Karolina


#3

I think there is something wrong with the latest firmware for M200 Plus. I too am having many problems with extruder heating of my 1 month old M200 Plus, many times the progression bar doesn’t even move from 0% and, in the meantime, the hotend is extremely hot. A few days ago my extruder was so hot that the white Teflon layer underneath the extruder became completely deformed and some smoke was produced as well. When this occurs, I can solve the issue stopping the heating process and restarting it. In this way, the second time the progress bar goes up normally. I also made sure all the cables are firmly plugged into the PCB and that the screws securing the heater&thermocouple in the hotend are tight.


#4

Hello!

I cannot reproduce this issue with the latest firmware.

Could you please roll back to the previous FW version one and check if it works well?

I think the extruder cable is the root. Please move it when the extruder is heating up and watch the progress bar.

Kind regards,

Marcin


#5

Same problem as Giufini and the firmware is 2.1.3… When i Unload the filament the progression bar doesn’t move. Then i cancel and start unload back and now the progression bar works .I don’t dare leave this machine alone anymore. I had this problem once.


#6

Hi!

I tried several times and couldn’t reproduce it. At least so far.

Could you check if the problem is there with the previous FW version?

Kind regards,

Marcin


#7

I too have also witnessed this heat the extruder so hot that the hotend had totally expanded and overcooked. this is generally when switching filaments. the progress bar doesnt move, the extruder cable has been reseated, the thermistor and the cartridge all removed and reseated, yet still has not fixed the issue.


#8

Hi, I have the same problem. Here the procedure I did:

Started my M200+
Change Filament
Nozzle starts heating, statusbar not progressing
(burning smell and smoke)
Turned off printer
Turned on M200+ and the error message appeared.
Turned off printer

In the last firmware everything worked perfectly.

Regards,

Tom


#9

I kinda fixed it but I dont know for how long. I first replaced everything once again. Checked the two screws in front of the hotend, extruder cable and pcb.

I also checked if there was any dust.

What I dont understand is and it kinda confuses me,
if you buy a high end printer that these problems can occur. If it was cheap, okay I get it, but a printer that costs over 2000 euro’s. It surpised me honestly.


#10

Hi Tom!

Could you check if it works well with the previous FW version? Please install the older version and please confrim if it’s ok then.

Kind regards,

Marcin


#11

Hi Marcin,

I reverted back to 2.1.2 and now when changing material, the temp statusbar is updating and unloads correctly without thermal runaway. (I did nothing with the hardware (extruder, thermistor, cables etc. only reverted back to 2.1.2)



#12

There is obviously a problem with the latest firmware. Everytime I try changing material when I switch on the M200 Plus and the extruder is cold (room temperature), the progress bar remains to 0% while the extruder got extremely hot. Please note that this error appears only when I try to change the filament, not when I start printing an object as first action, in this case in fact the display correctly shows the bed and extruder temperatures and they both increment correctly. I have even bought new extruder and sensors but I will not change them now because I am sure that the problem is with the firmware 2.1.3.


#13

Hi there, we are having the very same problem of broken control loop of temperature. As @giufini said the progression bar doesnt show the actual temperature. I guess is more a measuring problem that a graphical one.

When rolling back to version 2.1.1 the problem didnt appear on the load / unload secuences as previously but on reloading the same material this sign showed up:

Error: 2:4 Left Hotend: Heater Error

Hotend temp not raised ct 258, mt 257, tc60000

It seems that the temperature control management is in need of serious overhaul.


#14

Hi!

Is there any change after a while with the bar? Or nothing happens at all and finally you get an error message?

Kind regards,

Marcin


#15

The progress bar doesn’t move from 0%, even after several minutes (when CHANGE MATERIAL is the first thing I do after switching on the M200 Plus).
I didn’t have time to wait more since the teflon layer under the hotend was melted and deformed, so I stopped the material change procedure pressing the stop button (with 0% still on the display).
I suppose you can easily replicate this issue with the latest firmware because it happens ALWAYS and not randomly.
So please, fix this problem, I already had too many damages… Thanks.


#16

I tried several times today trying to replicate the error on firmware 2.1.1 without luck. Nevertheless I agree with Giufini that on the latest firmware the error is constant and consistent.


#17

It would be great updating the M200 Plus firmware to add info about the temperature of the hotend during the heating process of “change material” procedure. This would allow monitoring the correct heating of the hotend and of the corresponding updating of the progress bar. As you know, these values are shown on the bottom of the display when a print is started but, as I said, they would be highly useful also with the “material change” procedure.
Thank you.


#18

Everyone be very careful!

I downgraded the firmware of my M200 Plus from v2.1.3 to v2.1.2 but I am still having “Hotend Sensor failure” errors and incorrect updating of progress bar during extruder heating (when “Material Unload” is selected as the first action after switching on the printer) even after having installed a brand new HotEnd v3 and a brand new Heater and Thermocouple!

There is clearly something wrong with the v2.1.2 firmware as well.

Zortrax please, investigate this issue, this is a very serious and dangerous problem!

I think that firmware v2.1.2 and v2.1.3 should be removed as soon as possible from Zortrax download page since there is a critical fire hazard with using them. it is not prudent to recommend these firmware as “recommended versions”.

UPDATE: I downgraded the firmware of my M200 Plus from v2.1.2 to v2.1.1 and now I am not having any more “Hotend Sensor failure” errors and incorrect updating of progress bar during extruder heating (when “Material Unload” is selected as the first action after switching on the printer). So I highly recommend to everyone to downgrade the M200 Plus firmware to v2.1.1 for security reasons.


#19

We’re investigating this.


#20

Thank you Marcin.

Please note that today I had the already reported issue of “percentual value of heating not updating” (as usual when “Material Unload” is selected as the first action after switching on the printer) even with firmware v2.1.1!

What I noticed anyway, in this case, is that after a few seconds it has been shown on the screen the red message “Warning! Extruder is hot.” while the percentual value was still at 0%. So I stopped the heating process and immediately after I reselected the Material Unload command on the screen. As already noticed in previous similar situations, acting in this way allows the M200 Plus to correctly update the percentual value during the heating process.

I hope this can help to investigate the problem.