Z-Suite Performance TERRIBLE

Hello, I have just got my Inkspire, trying to make my first print… but it is OVER ONE HOUR waiting for “Generating Automatic Support” and its only 34% complete… I am afraid it won’t finish tomorrow too :frowning: :frowning: :frowning:

I am using Z-Suite on fresh install macOS 10.14.4.

How about adding some ready-to-go examples to the Z-Suite just for the first print?

Hi, @cederom.
Slicing complicated models can take some time, but we’re constantly working to improve Z-SUITE’s performance. Sending us some troublesome models would help us to expedite the development of our software.
As for the example models, we’ve uploaded a default one of the rook to Inkspires’ USB sticks. It can be used as a first/test print.

Thanks Marta for your reply :slight_smile: These models are not really complicated… CURA slices them in several seconds… looks like some bug in your slicer or really big optimization problem… I keep my fingers crossed for successful development… slicing that takes over 2h is far below acceptable timing :frowning:

Feel free to send me this file and the settings that you’ve used. I’ll check if the issue persists on our side and pass it to our specialists, it can help us improve the slicer.

I have noted this as well. I thought it might be my old laptop, so I pulled a HP Z440 6 core Xeon 1650 with 32GB of RAM from our computer pool and it does not seem any faster. I was testing support generation on the AmeraLabs resolution test, which is very complex, but only has two flat 45 degree overhangs that require supports, which took 15+ minutes. It is not the slicing that takes time, but the automatic support generation. If I don’t generate supports, it is very fast, just a few seconds.

Hey @Marta my suggestion would be to use existing Open-Source slicer - like CURA / CuraEngine - this way you would get something that already works fine with a decent quality and wide range of available options, then you can improve the code and share back the results making the Open-Source even better :slight_smile:

Thanks @Marta here goes the model - I am using 4x of them on one plate so that they can fit all together in one print :slight_smile: T800_Base_Supported_v5.4.5.stl (7.7 MB)

ps/2: I have prepared 7z file that is 7x smaller in size but cannot upload this kind of file here…

Pre-Slicing sux too - it goes to 98% and then stops for a really long time :frowning:

Update after 1h: Its now 99% wow…

Update just after: Going from 0% to 98% took several minutes… going from 98% to 100% took over an hour. Just for Pre-Slicing.

Preparing Support data over 30 minutes now… :frowning: :frowning: :frowning:

Update: Stopped at 49% since YESTERDAY !!!

I know what is the biggest current problem of Zortrax… and suprisingly its not the problem with a printers that comes well packed full of accessories ready to use… its the Z-Suite that makes you wonder and look for alternatives just after first use…


I have got Z-suite 2.8.3 on MacOS too, and I must admit that the performances are indeed terrible compared to Z-Suite on windows…

Slicing seem to be fast (but it’s not in fact!) on MacOS as it come very quickly to 100%… but nothing happens for a long moment when progress bar is at 100% and then suddenly after long minutes, the “generate” button appear and it’s done!

It’s not a particular problem with 2.8.3, I think it is slow since the beginning of version 2 on MacOs. Z-Suite v1 was faster for slicing, but was very slow to start on Mac…

1 Like

I have decided to try the Windows version on VirtualBox… unfortunately the 3D View is grey blank on all tabs - project, hardware, preferences…

it works fine with parallels on windows 10. :grinning:

but that’s a workaround, definitely not a solution for Mac users!!

Okay, @Marta, I can confirm that the Windows version works better on a PC machine with similar hardware configuration… faster (but still slow as hell) fast pre-slicing, support generation, slicing, etc.

Because GUI works fine on macOS while calculations are performed I guess you are using threads to launch calculate related tasks… you may want to increase priority of these tasks and that should improve performance on macOS.

Still serious algorithms+code optimization/rework seems unavoidable…

Thanks for hint on parallels @lollol13 but I try to stick to Open-Source only even on my macOS BSD… in a free moment I will try Win10 on VirtualBox :slight_smile:

In a perfect world I would see Z-Suite as Open-Source, maybe based on some mature existing solution such as CURA, so folks can send updates, I can also use it as a script on my WebApplication Backend to calculate costs of web submitted prints, etc, etc…

If you don’t want to release Z-Suite as Open-Source maybe you can release specification for your project files so Inkspire could be added to Open-Source solutions…

I don’t know if that helps, but on MacOS, first slicing after opening Z-Suite is slow… but second slicing is much faster, though not lightning fast…

Now I have 49% stuck at “Preparing Support Data” for several hours on Windows standalone machine… unbelievable :frowning:

I guess I need to wait for Z-Suite fixes. Until then my Inkspire seems useless… should I return it with refund and buy from other vendor? My clients rather don’t care about software problems they just want results for money on time… my time wasted on product testing is also wasted money with zero results :frowning:

I really keep my fingers crossed for Zortax success because this would be also my company success. Please take this problem seriously and make Z-Suite efficient, or propose some alternative solution that would just do the job.

Here goes the problematic file, like a previous one, but did a hollow inside manually. File is STL 7ZIPped renamed to STL to fit as attachment :slight_smile:

T800-hollow-7z.stl (5.8 MB)

Maybe you will be able to pinpoint and fix the problem after the break please :slight_smile:

Happy Easter! :slight_smile:

I tried to slice your STL and faces the same issues, whether on windows or on MacOS…

FYI I have to change the extension of your file, unzip it and reduce the size of your model down to 60%,so that it can fit into the inkspire…

Thanks @lollol13 :slight_smile: This is my standard model for testing stuff, nice huh? :slight_smile: Yes, I had to 7zip it then again change the extension to stl of the 7z file so it was possible to attach here :slight_smile:

Thank you for all your time and hints! Happy Easter! :slight_smile:

Hi there @cederom

So, basically STL is in terrible state, its pretty much notprintable. I tried to fix it using NetFabb and after few minutes I ran out of RAM. Anyway, I used external site (www.makeprintable.com) and theirs cloud service was able to repair it, but since its paid service now, you owe me 2$ :sunglasses:

repaired file (OBJ)

Hello @Marcin, thank you for your response :slight_smile:

The problem here is not with the model, but the current state of Zortrax Software, its (in)efficiency and adaptability… that badly impacts Inkspire use in production environments… I still consider to return and refund my recent purchase :frowning:

The hollow model was a quick and dirty hack of some source model that must be printed solid because Z-Suite does not allow to set shell thickness of the imported models for Inkspire. Setting shell thickness and infill type+density seems to be basic functionality in existing slicers to save building materials. It turns out, just by accident, that generated hollow model is a killer test for slicers :wink:

Also the performance of Z-Suite is not sufficient enough for production environments. Not to mention macOS version far slower than Windows version. And no version for Linux… or any Open-Source plans or alternatives… Waiting tens of minutes or more than hour for slicing discredits the solution in production environments.

Giving external paid tools, or exhausting RAM, is not a really convincing argument to use Zortrax, quite opposite, it works against it… may even prove you really don’t care about proper system resources utilization and code optimization. I am not going to build my own cloud just to have models sliced for Zortrax, because other free and open-source slicers do the job on standard desktop machine in a reasonable time… also I never had to use cloud to slice my models and I don’t feel I need to.

Is there any public schedule and/or timeline available to watch features development for Z-Suite?

Are there any plans to support Open-Source? Releasing Z-Suite as Open-Source? Implementing support for Inkspire in Open-Source (like CuraEngine)?

Best regards,