Zortrax Team,

I like your printer but Z-Suite just takes WAY TOO LONG to add supports to a model. Some of my models literally take 3 to 4 hours for Z-Suite to add supports. When I first started using Z-Suite the program was much faster in September/October (or maybe I was doing simpler models?).

Anyway you guys REALLY need to get on this. I'm running the latest Windows 10, I've got a great Graphics card, RAM, Hard Drive etc. so it isn't my computer.

Please make Z-Suite faster. This is just ridiculous. It's all good having a closed source printer/software package but the software really needs to perform at an acceptable speed. I just downloaded the latest 1.41 Z-Suite and again it's the same darn problem.

This latest model has taken me 4 hours to fully render:


This model took me 6 hours:


Thank you.

What filament type, Z-Suite version and Z-Suite settings were you using for the Santa slice operation?

My slice time for the Santa was a little less than 4 minutes for Z-ABS at 0.14 mm, light infill, and 10% support.  20% support increased that to 4-3/4 minutes and 45% support to  - well, it's still calculating.  I'll update when its done.

Later - I'm at 4h 42m and it is only 50% done at 45% support so it looks like support is some sort of problem.  This is on an HP ZP400 workstation with 12 GB of RAM and an SSD primary drive, so I don't think it's the CPU.

On the other hand that 45% support looks nearly impossible to remove and I'd take my chances with 10-20% support.  At that spec, the print would take around 4 hours, so not much would be lost if it doesn't work out.

Now I am going out on a limb here but it might actually be your computer... If the problem has not been reported before now and most every user on the forums uses Z-suit at its latest version without issue then it might not be Z-Suite.

I sliced the files in around 5 1/2 mins with Z-ABS and medium infill 140µ. 

Please post your computer setup and check your drivers for the GPU, chances are something is not up to date.


Yeah wonder what settings. Santa in about 6 minutes on my Mac in the background.

One thing: the file is 20 Mb. It seems to me like a lot of facets for that model. Who ever rendered it might want to turn that down a little. That would make it load and slice faster. 

Thanks guys it probably is my computer if all of you are taking so much shorter. However with the older (September or October version) Z-Suite it was taking only 4 to 6 minutes for a model this size.

It's still only at 29% as we speak now and I just put the Santa again when I sent my original message.

I put the settings at 0.09 Z-Abs, Solid...

I haven't changed anything as far as my computer goes in the last few months except for putting Windows 10 on. Any suggestions welcome as to what's causing this.

Sorry about the fuss Zortrax.

It's really weird cause I'll hit the print setting on a model and then it starts rendering like it used to but always gets stuck at the 29% mark and then it just lingers for hours. I have no idea what to do (except blame it on Bill Gates... that always gives one some solace)...

Btw any smaller model Z-Suite will go through in literally 3 or 4 minutes...

I just wanted to add my Computer stats in case anyone had any bright ideas:

Windows 10 Pro

CPU: Intel (R) Core (TM) i7-3770 CPU @ 3.40GHz 3.40GHz

Installed RAM 8.00 GB

System Type 64-bit operating system, x64-based processor

Maybe you have Malicious software running in the background causing your CPU to run slow or overloaded

Did you make a clean Win10 install or was it over Win8? Win8 is shit (my unhumble opinion) and putting Win10 on top of it wouldn't be the optimal solution.

Can you list *all* of the Z-Suite settings that you are using?

@Andy_B  I've checked my CPU usage and there isn't any malwear using it up. All other programs run fine

@MichaelHenry what do you mean by my Z-Suite settings?

My current Z-Suite is versions 1.41

He means Infill option, layer height, speed setting, support type, fan setting, basically anything you can click in the print menu. A picture with the advanced window open will be just fine.


What Night Shift said.  If you specify the settings, then others can trying slicing the same file and give you feedback.  Without that information people are just shooting in the dark.

@MichaelHenry what do you mean by my Z-Suite settings?

My current Z-Suite is versions 1.41

Interesting. I tried and all was going well until the 29% mark as well. Maybe software maybe model issue?

I’m running windows 7, 8gigs ram, 64 bit, i7-3610qm processor. Z-suite V1.3.0

7   minutes running Z-suite 1.2.2   in Windows Xp  from Linux Mint  64 bit  via Virtual box with software 3d drivers.

In my tests, the amount of support had a *very* significant impact on slicing time.  The OP's print file appears to be the same as one that was uploaded to Thingiverse where the uploader mentioned that it had been printed by an SLS printer.  What say you 3D print experts - is this file printable on an FDM printer like the Zortrax M200?


Sorry for replying so late. I ended up reinstalling Windows which was a total disaster. I still have the same problem with the Zortrax 1.4.1 software. Any large print or print requiring lots of supports gets stuck at 29% in the software.

I tried with Z-Suite 1.2.2 and it at least finishes most of the projects but still takes forever.

I've also tried this now on another computer and I've been having the same problem.

@NightShift & MichaelHenry

As far as the settings go I've basically tried them all for Z-Ultrat and Z-ABS





Speed is always set to normal

Infill: Full/Solid/Medium/Light

I always use Support light but have tried running the models with normal support and the same thing happens.

Fan Speed is always set to normal.

*I never use the advanced settings.


The problem isn't just SLS prints. It's any large print. Z-Suite only slices until 29% and then stops functioning. I never had this problem with previous versions of Z-Suite.

I've literally reinstalled Windows, deleted all my programs, reinstalled maybe half the stuff I had on before and Z-Suite is still doing the same :(

Anyway thank you everyone for helping. It's much appreciated. And a Happy New Year to you all :)